The enumerated type representing the permitted values for the asset property "WaterType" from the "Water" schema.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public enum WaterType
Visual Basic
Public Enumeration WaterType
Visual C++
public enum class WaterType

Members

Member nameDescription
SwimmingPool
ReflectingPool
River
Lake
Ocean

See Also