Identify whether the input points are distinct in XY location.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public static bool ArePointsDistinct(
	IList<XYZ> points
)
Visual Basic
Public Shared Function ArePointsDistinct ( _
	points As IList(Of XYZ) _
) As Boolean
Visual C++
public:
static bool ArePointsDistinct(
	IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The points set to be checked.

Return Value

True if all points are distinct after ignoring the elevations, otherwise false.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException There are no points in the input points set.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also