Initializes a new instance of the FamilyInstanceCreationData class
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyInstanceCreationData( Face face, Line position, FamilySymbol symbol ) |
Visual Basic |
---|
Public Sub New ( _ face As Face, _ position As Line, _ symbol As FamilySymbol _ ) |
Visual C++ |
---|
public: FamilyInstanceCreationData( Face^ face, Line^ position, FamilySymbol^ symbol ) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
- position
- Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.