Create a non-spiral shape definition.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public RebarShapeDefinitionByArc( Document doc, RebarShapeDefinitionByArcType type ) |
Visual Basic |
---|
Public Sub New ( _ doc As Document, _ type As RebarShapeDefinitionByArcType _ ) |
Visual C++ |
---|
public: RebarShapeDefinitionByArc( Document^ doc, RebarShapeDefinitionByArcType type ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
Remarks
Replaces RebarShape.NewDefinitionByArc() from prior versions.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |