RebarShapeDefinitionByArc(Document, RebarShapeDefinitionByArcType) Constructor

Create a non-spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeDefinitionByArc(
	Document doc,
	RebarShapeDefinitionByArcType type
)

Parameters

doc  Document
 
type  RebarShapeDefinitionByArcType
 
Exceptions
ExceptionCondition
ArgumentException The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
Replaces RebarShape.NewDefinitionByArc() from prior versions.
See Also