Validates that the element is from an appropriate document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool IsElementFromAppropriateContext( Element element ) |
Visual Basic |
---|
Public Shared Function IsElementFromAppropriateContext ( _ element As Element _ ) As Boolean |
Visual C++ |
---|
public: static bool IsElementFromAppropriateContext( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The solid to be cut or the cutting solid.
Return Value
True if the element is from an appropriate document for solid-solid cuts, false otherwise.
Remarks
Currently an element from either a project document, conceptual model, pattern based curtain panel, or adaptive component family
may participate in solid-solid cuts.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |