Checks if given type is valid HVAC system type.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool IsHvacSystemTypeId( Document document, ElementId systemTypeId ) |
Visual Basic |
---|
Public Shared Function IsHvacSystemTypeId ( _ document As Document, _ systemTypeId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsHvacSystemTypeId( Document^ document, ElementId^ systemTypeId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- systemTypeId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the HVAC system type to check.
Return Value
True if the given systemTypeId is the HVAC system type, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |