Constructs a new instance of a filter to match elements with a bounding box that contains the given point,
while specifying the tolerance to be used in deciding if the point matches the criteria.
This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public BoundingBoxContainsPointFilter(
XYZ point,
double tolerance,
bool inverted
) |
Visual Basic |
---|
Public Sub New ( _
point As XYZ, _
tolerance As Double, _
inverted As Boolean _
) |
Visual C++ |
---|
public:
BoundingBoxContainsPointFilter(
XYZ^ point,
double tolerance,
bool inverted
) |
Parameters
- point
- Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box containing it.
- tolerance
- Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.
- inverted
- Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
See Also