BoundingBoxContainsPointFilter(XYZ, Double, Boolean) Constructor |
Constructs a new instance of a filter to match elements with a bounding box that contains the given point,
while specifying the tolerance to be used in deciding if the point matches the criteria.
This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxContainsPointFilter(
XYZ point,
double tolerance,
bool inverted
)
Public Sub New (
point As XYZ,
tolerance As Double,
inverted As Boolean
)
public:
BoundingBoxContainsPointFilter(
XYZ^ point,
double tolerance,
bool inverted
)
new :
point : XYZ *
tolerance : float *
inverted : bool -> BoundingBoxContainsPointFilter
Parameters
- point XYZ
-
The point used to find elements with a bounding box containing it.
- tolerance Double
-
The tolerance value to use instead of zero. See the tolerance property for details.
- inverted Boolean
-
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
See Also