Obtains the IFC-specific information regarding the connections between this wall and other elements.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static IList<IFCConnectedWallData> GetConnectedWalls( Wall pWallElem, IFCConnectedWallDataLocation locaction ) |
Visual Basic |
---|
Public Shared Function GetConnectedWalls ( _ pWallElem As Wall, _ locaction As IFCConnectedWallDataLocation _ ) As IList(Of IFCConnectedWallData) |
Visual C++ |
---|
public: static IList<IFCConnectedWallData^>^ GetConnectedWalls( Wall^ pWallElem, IFCConnectedWallDataLocation locaction ) |
Parameters
- pWallElem
- Type: Autodesk.Revit.DB..::..Wall
The wall.
- locaction
- Type: Autodesk.Revit.DB.IFC..::..IFCConnectedWallDataLocation
The location on the wall from where the connections should be obtained. This should be either IFCConnectedWallDataLocation.Start or IFCConnectedWallDataLocation.End.
Return Value
The connection information.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |