Identifies if the input element is supported by element intersection filters.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool IsElementSupported( Element element ) |
Visual Basic |
---|
Public Shared Function IsElementSupported ( _ element As Element _ ) As Boolean |
Visual C++ |
---|
public: static bool IsElementSupported( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The element.
Return Value
True if the element is supported, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |