Identifies whether the given point exists in the topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool ContainsPoint( XYZ point ) |
Visual Basic |
---|
Public Function ContainsPoint ( _ point As XYZ _ ) As Boolean |
Visual C++ |
---|
public: bool ContainsPoint( XYZ^ point ) |
Parameters
- point
- Type: Autodesk.Revit.DB..::..XYZ
The point to be checked.
Return Value
True if the input point exists in the topography surface, otherwise false.
Remarks
The given point will be evaluated in XYZ. If a point matches the XY location, but not the elevation, this function still returns false.
This applies to TopographySurface and SiteSubRegion elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |