TopographySurfaceContainsPoint Method |
Identifies whether the given point exists in the topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ContainsPoint(
XYZ point
)
Public Function ContainsPoint (
point As XYZ
) As Boolean
public:
bool ContainsPoint(
XYZ^ point
)
member ContainsPoint :
point : XYZ -> bool
Parameters
- point XYZ
-
The point to be checked.
Return Value
Boolean
True if the input point exists in the topography surface, otherwise false.
Exceptions
Remarks
The given point will be evaluated in XYZ. If a point matches the XY location, but not the elevation, this function still returns false.
This applies to TopographySurface and SiteSubRegion elements.
See Also