Converts a placeholder sheet to a real one with an optional titleblock.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void ConvertToRealSheet( ElementId titleBlockTypeId ) |
Visual Basic |
---|
Public Sub ConvertToRealSheet ( _ titleBlockTypeId As ElementId _ ) |
Visual C++ |
---|
public: void ConvertToRealSheet( ElementId^ titleBlockTypeId ) |
Parameters
- titleBlockTypeId
- Type: Autodesk.Revit.DB..::..ElementId
The id of the placeholder sheet, or invalidElementId if no titleblock should be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | titleBlockTypeId does not correspond to a TitleBlock type. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This method may only be called on a placeholder sheet. -or- Failed to convert the sheet because the input titleblock could not be applied. |