ViewSheetConvertToRealSheet Method

Converts a placeholder sheet to a real one with an optional titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConvertToRealSheet(
	ElementId titleBlockTypeId
)

Parameters

titleBlockTypeId  ElementId
The id of the placeholder sheet, or invalidElementId if no titleblock should be added.
Exceptions
ExceptionCondition
ArgumentException titleBlockTypeId does not correspond to a TitleBlock type.
ArgumentNullException A non-optional argument was null
InvalidOperationException This method may only be called on a placeholder sheet. -or- Failed to convert the sheet because the input titleblock could not be applied.
See Also