Selects the elements.
Namespace: Autodesk.Revit.UI.SelectionAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetElementIds( ICollection<ElementId> elementIds ) |
Visual Basic |
---|
Public Sub SetElementIds ( _ elementIds As ICollection(Of ElementId) _ ) |
Visual C++ |
---|
public: void SetElementIds( ICollection<ElementId^>^ elementIds ) |
Parameters
- elementIds
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The ids of the elements to be selected.
Remarks
This function will select the specified elements and update the UI.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |