Gets a SchedulableField object representing this field.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public SchedulableField GetSchedulableField() |
Visual Basic |
---|
Public Function GetSchedulableField As SchedulableField |
Visual C++ |
---|
public: SchedulableField^ GetSchedulableField() |
Return Value
The SchedulableField object.
Remarks
A ScheduleableField cannot be obtained for:
- Calculated fields
- Combined parameters
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InapplicableDataException | This ScheduleField is not a schedulable field by type(non-calculated/non-combined-parameter). |