Validates that the wall is of a type that may be a host for a wall sweep or reveal.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool WallAllowsWallSweep( Wall wall ) |
Visual Basic |
---|
Public Shared Function WallAllowsWallSweep ( _ wall As Wall _ ) As Boolean |
Visual C++ |
---|
public: static bool WallAllowsWallSweep( Wall^ wall ) |
Parameters
- wall
- Type: Autodesk.Revit.DB..::..Wall
The wall.
Return Value
True if the wall may host a wall sweep, false otherwise.
Remarks
This function excludes curtain walls and the main wall of a set of stacked walls.
The wall must be fully regenerated for this function to work correctly.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |