WallSweepWallAllowsWallSweep Method |
Validates that the wall is of a type that may be a host for a wall sweep or reveal.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool WallAllowsWallSweep(
Wall wall
)
Public Shared Function WallAllowsWallSweep (
wall As Wall
) As Boolean
public:
static bool WallAllowsWallSweep(
Wall^ wall
)
static member WallAllowsWallSweep :
wall : Wall -> bool
Parameters
- wall Wall
-
The wall.
Return Value
Boolean
True if the wall may host a wall sweep, false otherwise.
Exceptions
Remarks
This function excludes curtain walls and the main wall of a set of stacked walls.
The wall must be fully regenerated for this function to work correctly.
See Also