Checks that the value is a valid value for this property.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018.1

Syntax

C#
public bool IsValidValue(
	XYZ xyz
)
Visual Basic
Public Function IsValidValue ( _
	xyz As XYZ _
) As Boolean
Visual C++
public:
bool IsValidValue(
	XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.DB..::..XYZ
The value to be checked.

Return Value

True if the value is valid for the property.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException Cannot check validity for a property not being edited in AppearanceAssetEditScope.

See Also