Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public double WidthScale { get; set; } |
Visual Basic |
---|
Public Property WidthScale As Double Get Set |
Visual C++ |
---|
public: property double WidthScale { double get (); void set (double value); } |
Remarks
If LockProportions is true, then changes to the WidthScale will also result in changes to the HeightScale.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for widthScale results in a width that is more than 30000 feet. -or- When setting this property: The given value for widthScale results in a height that is more than 30000 feet because LockProportions is set to true. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for widthScale must be non-negative. |