Adds a new AssetPropertyDouble4 property to the list containing a value matching the input color.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public void AddNewAssetAsColor( Color value ) |
Visual Basic |
---|
Public Sub AddNewAssetAsColor ( _ value As Color _ ) |
Visual C++ |
---|
public: void AddNewAssetAsColor( Color^ value ) |
Parameters
- value
- Type: Autodesk.Revit.DB..::..Color
The color value to add.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The asset property is not editable. |