Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function AddMullions ( _
segment As Curve, _
mullionType As MullionType, _
oneSegmentOnly As Boolean _
) As ElementSet |
Parameters
- segment
- Type: Autodesk.Revit.DB..::..Curve
Curve of the segment.
- mullionType
- Type: Autodesk.Revit.DB..::..MullionType
The type of the mullion to add.
- oneSegmentOnly
- Type: System..::..Boolean
If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.
Return Value
If operation succeeds, the created mullions will be returned.
Exceptions
See Also