Sets the merged cell that this cell is a part of.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetMergedCell( int nRow, int nCol, TableMergedCell mergedCell ) |
Visual Basic |
---|
Public Sub SetMergedCell ( _ nRow As Integer, _ nCol As Integer, _ mergedCell As TableMergedCell _ ) |
Visual C++ |
---|
public: void SetMergedCell( int nRow, int nCol, TableMergedCell^ mergedCell ) |
Parameters
- nRow
- Type: System..::..Int32
The cell row.
- nCol
- Type: System..::..Int32
The cell column.
- mergedCell
- Type: Autodesk.Revit.DB..::..TableMergedCell
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The given TableMergedCell mergedCell is outside of acceptable range. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections. |