Gets the collection of design elements that failed to convert and the associated set of fabrication parts with open connectors.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public IDictionary<ElementId, ISet<ElementId>> GetDesignElementAndFabricationPartsWithOpenConnectors() |
Visual Basic |
---|
Public Function GetDesignElementAndFabricationPartsWithOpenConnectors As IDictionary(Of ElementId, ISet(Of ElementId)) |
Visual C++ |
---|
public: IDictionary<ElementId^, ISet<ElementId^>^>^ GetDesignElementAndFabricationPartsWithOpenConnectors() |
Return Value
A map of design element identifiers that were not converted and the associated set fabrication parts left with open connectors.
Remarks
This set of element identifiers is only available after the Convert method has been invoked, and returns DesignToFabricationConverterResult::Enum::PartialFailure.