This class represents the MEP design to fabrication part convert tool.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public class DesignToFabricationConverter : IDisposable |
Visual Basic |
---|
Public Class DesignToFabricationConverter _ Implements IDisposable |
Visual C++ |
---|
public ref class DesignToFabricationConverter : IDisposable |
Remarks
After a new instance of the class is created, call the Convert method to convert the MEP design elements into
fabrication parts. After the convert method has been invoked, query the class to obtain more information about the conversion:
- GetConvertedFabricationParts()()()() to get a set of element identifiers for the newly created fabrication parts.
- GetElementsWithOpenConnector()()()() to get a set of fabrication part or MEP design element identifiers with open connectors, caused by fittings failing to convert.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Fabrication..::..DesignToFabricationConverter
Autodesk.Revit.DB.Fabrication..::..DesignToFabricationConverter