Creates a selector based on a specific analytical curve.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public AnalyticalModelSelector( Curve curve ) |
Visual Basic |
---|
Public Sub New ( _ curve As Curve _ ) |
Visual C++ |
---|
public: AnalyticalModelSelector( Curve^ curve ) |
Parameters
- curve
- Type: Autodesk.Revit.DB..::..Curve
The curve upon which this selector acts.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |