AnalyticalModelSelector(Curve) Constructor

Creates a selector based on a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AnalyticalModelSelector(
	Curve curve
)

Parameters

curve  Curve
The curve upon which this selector acts.
Exceptions
ExceptionCondition
ArgumentException The input curve points to a helical curve and is not supported for this operation.
ArgumentNullException A non-optional argument was null
See Also