The icon shown in the task dialog.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public TaskDialogIcon MainIcon { get; set; } |
Visual Basic |
---|
Public Property MainIcon As TaskDialogIcon Get Set |
Visual C++ |
---|
public: property TaskDialogIcon MainIcon { TaskDialogIcon get (); void set (TaskDialogIcon value); } |
Remarks
There is no icon by default.
Task dialogs in Revit rarely use icons, to reduce the visual clutter shown to the user. Only one icon can be used in the task dialog, the Warning (!) icon, and it should be used only when there is a risk of data loss or significant time lost. If there is no data loss or time lost as a possible result of the message, do not use the icon.