TaskDialogMainIcon Property |
The icon shown in the task dialog.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TaskDialogIcon MainIcon { get; set; }
Public Property MainIcon As TaskDialogIcon
Get
Set
public:
property TaskDialogIcon MainIcon {
TaskDialogIcon get ();
void set (TaskDialogIcon value);
}
member MainIcon : TaskDialogIcon with get, set
Property Value
TaskDialogIcon
Remarks There is no icon by default.
Task dialogs in Revit rarely use icons, to reduce the visual clutter shown to the user. Only one icon can be used
in the task dialog, the Warning (!) icon, and it should be used only when there is a risk of data loss or
significant time lost. If there is no data loss or time lost as a possible result of the message, do not use the icon.
See Also