Constructs the vertex buffer with the given capacity, measured in floats.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public VertexBuffer( int sizeInFloats ) |
Visual Basic |
---|
Public Sub New ( _ sizeInFloats As Integer _ ) |
Visual C++ |
---|
public: VertexBuffer( int sizeInFloats ) |
Parameters
- sizeInFloats
- Type: System..::..Int32
The number of floats that the buffer can contain.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This VertexBuffer is not available because Revit is not currently rendering. In general, this VertexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |