Constructs the vertex buffer with the given capacity, measured in floats.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VertexBuffer(
int sizeInFloats
)
Public Sub New (
sizeInFloats As Integer
)
public:
VertexBuffer(
int sizeInFloats
)
new :
sizeInFloats : int -> VertexBuffer
Parameters
- sizeInFloats Int32
-
The number of floats that the buffer can contain.
ExceptionsException | Condition |
---|
InvalidOperationException |
This VertexBuffer is not available because Revit is not currently rendering. In general, this VertexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also