Choice of two possibilities for the start and end references of the length constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType( int index ) |
Visual Basic |
---|
Public Function GetSegmentEndReferenceType ( _ index As Integer _ ) As RebarShapeSegmentEndReferenceType |
Visual C++ |
---|
public: RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType( int index ) |
Parameters
- index
- Type: System..::..Int32
Which reference on the constraint. Either 0 or 1.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | index is not 0 or 1. |