RebarShapeConstraintProjectedSegmentLengthGetSegmentEndReferenceType Method

Choice of two possibilities for the start and end references of the length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
	int index
)

Parameters

index  Int32
Which reference on the constraint. Either 0 or 1.

Return Value

RebarShapeSegmentEndReferenceType
Exceptions
ExceptionCondition
ArgumentException index is not 0 or 1.
See Also