Checks that the service type falls within an appropriate range.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool CheckServiceType( gbXMLServiceType serviceType ) |
Visual Basic |
---|
Public Shared Function CheckServiceType ( _ serviceType As gbXMLServiceType _ ) As Boolean |
Visual C++ |
---|
public: static bool CheckServiceType( gbXMLServiceType serviceType ) |
Parameters
- serviceType
- Type: Autodesk.Revit.DB.Analysis..::..gbXMLServiceType
The service type to be checked.
Return Value
True if the service type falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |