Removes element ids from the connection. All element ids in an array should belong to the connection.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public void RemoveElementIds(
	IList<ElementId> elemIds
)
Visual Basic
Public Sub RemoveElementIds ( _
	elemIds As IList(Of ElementId) _
)
Visual C++
public:
void RemoveElementIds(
	IList<ElementId^>^ elemIds
)

Parameters

elemIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The ElementIdArr containing ids of elements to be removed.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One or more element ids was not permitted to be removed from the connection. Elements should be members of the connection.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also