The Document Creation object is used to create new instances of elements within the
Autodesk Revit project.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class Document : ItemFactoryBase |
Visual Basic |
---|
Public Class Document _ Inherits ItemFactoryBase |
Visual C++ |
---|
public ref class Document : public ItemFactoryBase |
Remarks
The Document Creation object is a utility object that is used to create new
instances of elements within the Autodesk Revit project. This object, available from the
Document.Create property should be used to create elements instead of using New. This
object ensures that the elements created are added to the document correctly.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..Document
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..Document