The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class ItemFactoryBase : APIObject
Visual Basic
Public Class ItemFactoryBase _
	Inherits APIObject
Visual C++
public ref class ItemFactoryBase : public APIObject

Remarks

The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. This class holds common methods used in both project documents and family documents.

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB..::..APIObject
    Autodesk.Revit.Creation..::..ItemFactoryBase
      Autodesk.Revit.Creation..::..Document
      Autodesk.Revit.Creation..::..FamilyItemFactory

See Also