Retrieves analytical model projection information for Y direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public ElementId GetProjectionPlaneY(
	AnalyticalElementSelector selector
)
Visual Basic
Public Function GetProjectionPlaneY ( _
	selector As AnalyticalElementSelector _
) As ElementId
Visual C++
public:
ElementId^ GetProjectionPlaneY(
	AnalyticalElementSelector selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.

Return Value

Plane on to which analytical model is projected, or invalidElementId if not projected to a Plane.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also