The beginningIndent is an offset distance from the beginning of the
first curve that determines the beginning of the range over which
the layout is applied.
The measurement type determines how the distance is measured.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double BeginningIndent { get; set; } |
Visual Basic |
---|
Public Property BeginningIndent As Double Get Set |
Visual C++ |
---|
public: property double BeginningIndent { double get (); void set (double value); } |
Remarks
BeginningIndent and endIndent are not allowed to overlap
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for beginningIndent must be between 0 and 30000 feet. -or- When setting this property: beginningIndent overlaps with endIndent |