Retrieves the curve providing support.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public Curve GetCurve() |
Visual Basic |
---|
Public Function GetCurve As Curve |
Visual C++ |
---|
public: Curve^ GetCurve() |
Return Value
Represents the curve providing support, if the Support Type is Curve Support.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the Support Type is not Curve Support. |