Represents one support for an Element, in the realm of the Analytical Model.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class AnalyticalModelSupport : IDisposable |
Visual Basic |
---|
Public Class AnalyticalModelSupport _ Implements IDisposable |
Visual C++ |
---|
public ref class AnalyticalModelSupport : IDisposable |
Remarks
Analytical Support has been defined as if and how an Element is supported, by looking at
the Analytical Models of Elements. There are different priorities of support, and different
types of support. Additionally, even though an Element has supports, it may not be
fully supported.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalModelSupport
Autodesk.Revit.DB.Structure..::..AnalyticalModelSupport