Manipulates the crease on the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void ModifySubElement( SlabShapeCrease crease, double offset ) |
Visual Basic |
---|
Public Sub ModifySubElement ( _ crease As SlabShapeCrease, _ offset As Double _ ) |
Visual C++ |
---|
public: void ModifySubElement( SlabShapeCrease^ crease, double offset ) |
Parameters
- crease
- Type: Autodesk.Revit.DB..::..SlabShapeCrease
The crease.
- offset
- Type: System..::..Double
The new value of the crease offset, which is the average of offsets of its ends.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the crease is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the crease is invalid. |