Checks if the ElementId is a mass family instance.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool IsMassFamilyInstance( Document document, ElementId id ) |
Visual Basic |
---|
Public Shared Function IsMassFamilyInstance ( _ document As Document, _ id As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsMassFamilyInstance( Document^ document, ElementId^ id ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- id
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId to be checked.
Return Value
True if the ElementId is a mass family instance, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |