Checks whether this FormatOptions is valid for a given unit type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidForSpec(ForgeTypeId)` method instead.")] public bool IsValidForUnitType( UnitType unitType ) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidForSpec(ForgeTypeId)` method instead.")> _ Public Function IsValidForUnitType ( _ unitType As UnitType _ ) As Boolean |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidForSpec(ForgeTypeId)` method instead.")] public: bool IsValidForUnitType( UnitType unitType ) |
Parameters
- unitType
- Type: Autodesk.Revit.DB..::..UnitType
The unit type.
Return Value
True if the FormatOptions is valid, false otherwise.
Remarks
The FormatOptions is valid if UseDefault is true or if the display
unit in the FormatOptions is valid for the unit type. See
UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType)
and
UnitUtils.GetValidDisplayUnits(UnitType).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | unitType is an invalid unit type. See UnitUtils.IsValidUnitType() and UnitUtils.GetValidUnitTypes(). |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |