Checks whether a display unit is valid for a given unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidUnit(ForgeTypeId, ForgeTypeId)` method instead.")]
public static bool IsValidDisplayUnit(
	UnitType unitType,
	DisplayUnitType displayUnit
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidUnit(ForgeTypeId, ForgeTypeId)` method instead.")> _
Public Shared Function IsValidDisplayUnit ( _
	unitType As UnitType, _
	displayUnit As DisplayUnitType _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidUnit(ForgeTypeId, ForgeTypeId)` method instead.")]
public:
static bool IsValidDisplayUnit(
	UnitType unitType, 
	DisplayUnitType displayUnit
)

Parameters

unitType
Type: Autodesk.Revit.DB..::..UnitType
The unit type.
displayUnit
Type: Autodesk.Revit.DB..::..DisplayUnitType
The display unit to check.

Return Value

True if the display unit is valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException unitType is an invalid unit type. See UnitUtils.IsValidUnitType() and UnitUtils.GetValidUnitTypes().
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also