Creates a new instance of a divided path whose points are determined by the intersecting elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static DividedPath Create( Document document, IList<Reference> curveReferences, ICollection<ElementId> intersectors ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ curveReferences As IList(Of Reference), _ intersectors As ICollection(Of ElementId) _ ) As DividedPath |
Visual C++ |
---|
public: static DividedPath^ Create( Document^ document, IList<Reference^>^ curveReferences, ICollection<ElementId^>^ intersectors ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- curveReferences
- Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
References that represent a connected set of curves or edges.
- intersectors
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Elements whose intersection with the curve references result in additional divisions.
Return Value
The newly created divided path.
Remarks
Intersectors can be curve elements, datum planes, or other divided paths.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected. -or- Not all intersecting elements in intersectors are valid. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |