DividedPathCreate(Document, IListReference, ICollectionElementId) Method |
Creates a new instance of a divided path whose points are determined by the intersecting elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static DividedPath Create(
Document document,
IList<Reference> curveReferences,
ICollection<ElementId> intersectors
)
Public Shared Function Create (
document As Document,
curveReferences As IList(Of Reference),
intersectors As ICollection(Of ElementId)
) As DividedPath
public:
static DividedPath^ Create(
Document^ document,
IList<Reference^>^ curveReferences,
ICollection<ElementId^>^ intersectors
)
static member Create :
document : Document *
curveReferences : IList<Reference> *
intersectors : ICollection<ElementId> -> DividedPath
Parameters
- document Document
-
The document.
- curveReferences IListReference
-
References that represent a connected set of curves or edges.
- intersectors ICollectionElementId
-
Elements whose intersection with the curve references result in additional divisions.
Return Value
DividedPath
The newly created divided path.
ExceptionsException | Condition |
---|
ArgumentException |
The document does not allow creation of a divided path.
-or-
Not all curve references in curveReferences represent a curve or an edge
-or-
The references in curveReferences are not connected.
-or-
Not all intersecting elements in intersectors are valid.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
Intersectors can be curve elements, datum planes, or other divided paths.
See Also