Adds a new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public RebarFreeFormValidationResult AddBarGeometry( CurveLoop curves ) |
Visual Basic |
---|
Public Function AddBarGeometry ( _ curves As CurveLoop _ ) As RebarFreeFormValidationResult |
Visual C++ |
---|
public: RebarFreeFormValidationResult AddBarGeometry( CurveLoop^ curves ) |
Parameters
- curves
- Type: Autodesk.Revit.DB..::..CurveLoop
Curves describing one bar in the set.
Return Value
Returns Success if everything is ok, otherwise the failure reason.
Remarks
This function can fail due to following reasons:
- CurveLoop is empty.
- CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Incorrect number of bar geometry. |