The class that contains the information needed to calculate and return the curves in a trimmed/extended state, and also find the constraints that trim/extend it.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public class RebarTrimExtendData : IDisposable |
Visual Basic |
---|
Public Class RebarTrimExtendData _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarTrimExtendData : IDisposable |
Remarks
If new curves will be added by calling addBarGeometry(), the existing curves in Rebar element will be replaced with these curves. It will not add curves to the existing ones.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarTrimExtendData
Autodesk.Revit.DB.Structure..::..RebarTrimExtendData